NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2017-1000009 — pim-community-dev

CRITICAL

CVE-2017-1000009 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in akeneo/pim-community-dev. A fix is available for akeneo/pim-community-dev — see the affected versions and patch details below.

Akeneo PIM vulnerable to shell injection in the mass edition

Also known asGHSA-q8cr-xphm-7gfv
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
1.97%5.45%8.93%12.4%10.5%3.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘akeneo/pim-community-dev🐘akeneo/pim-community-dev🐘akeneo/pim-community-dev

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Akeneo PIM CE and EE <1.6.6, <1.5.15, <1.4.28 are vulnerable to shell injection in the mass edition, resulting in remote execution.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistakeneo/pim-community-dev≥ 1.4&&< 1.4.281.4.28composer require akeneo/pim-community-dev:^1.4.28
🐘Packagistakeneo/pim-community-dev≥ 1.5&&< 1.5.151.5.15composer require akeneo/pim-community-dev:^1.5.15
🐘Packagistakeneo/pim-community-dev≥ 1.6&&< 1.6.61.6.6composer require akeneo/pim-community-dev:^1.6.6

Affected Products

1 product · 118 configurations
Application
product information managementakeneo
49 versions
1.4.01.4.11.4.21.4.31.4.41.4.51.4.61.4.71.4.81.4.91.4.101.4.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for akeneo/pim-community-dev, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update akeneo/pim-community-dev to 1.4.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000009 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Akeneo PIM CE and EE <1.6.6, <1.5.15, <1.4.28 are vulnerable to shell injection in the mass edition, resulting in remote execution.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000009 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-1000009: pim-community-dev — Fixed in 1.4.28