CVE-2016-9909 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in html5lib. A fix is available for html5lib — see the affected versions and patch details below.
Improper Neutralization of Input During Web Page Generation in html5lib
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
html5libReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | html5lib | all versions | 0.999999999pip install --upgrade 'html5lib==0.999999999' |
Affected Products
html5libhtml5libDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for html5lib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update html5lib to 0.999999999 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9909 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2016-9909 in your dependencies?
Find it across PyPI, including transitive dependencies.