Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2016-9299 — jenkins-core

CRITICALFix: jenkinsci/jenkins@6078dd7

CVE-2016-9299 is a critical-severity (CVSS 9.8) CWE-90 vulnerability in org.jenkins-ci.main:jenkins-core. 2 public exploit references exist, so weaponization risk is real. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Improper Neutralization of Special Elements used in an LDAP Query in Jenkins

Also known asGHSA-2x9h-h3c4-wqqh
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
96.9%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
86.7%91.2%95.6%100.0%89.3%96.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2016-9299 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 396,966 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers to execute arbitrary code via a crafted serialized Java object, which triggers an LDAP query to a third-party server.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 2.20&&< 2.322.32org.jenkins-ci.main:jenkins-core:2.32
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions2.19.3org.jenkins-ci.main:jenkins-core:2.19.3

Affected Products

2 products · 3 configurations
OS
fedorafedoraproject
1 version
25
Application
jenkinsjenkins
≤ 2.31
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44642remotelinux✓ Verified

Jenkins CLI - HTTP Java Deserialization (Metasploit)

by Metasploit · May 17, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 2.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9299 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
Workaround published by Red Hat
https://github.com/jenkinsci-cert/SECURITY-218
Source: Red Hat security advisory for CVE-2016-9299 (CC BY 4.0)

Frequently Asked Questions

The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers to execute arbitrary code via a crafted serialized Java object, which triggers an LDAP query to a third-party server.
O3 Security · Impact-Aware SCA

Is CVE-2016-9299 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-9299: jenkins-core RCE — Fixed in 2.32