NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2016-9122 — square/go-jose.v1

HIGHFix: square/go-jose@2c5656a

CVE-2016-9122 is a high-severity (CVSS 7.5) CWE-284 vulnerability in gopkg.in/square/go-jose.v1. A fix is available for gopkg.in/square/go-jose.v1 — see the affected versions and patch details below.

Go JOSE Signature Validation Bypass

Also known asGHSA-77gc-fj98-665hGO-2022-0945
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.82%1.65%2.47%0.3%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹gopkg.in/square/go-jose.v1

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

go-jose before 1.0.4 suffers from multiple signatures exploitation. The go-jose library supports messages with multiple signatures. However, when validating a signed message the API did not indicate which signature was valid, which could potentially lead to confusion. For example, users of the library might mistakenly read protected header values from an attached signature that was different from the one originally validated.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogopkg.in/square/go-jose.v1all versions1.1.0go get gopkg.in/square/go-jose.v1@v1.1.0

Affected Products

1 product · 1 configurations
Application
go-josego-jose_project
≤ 1.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gopkg.in/square/go-jose.v1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update gopkg.in/square/go-jose.v1 to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9122 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Go JOSE before 1.1.0 suffers from multiple signatures exploitation. The go-jose library supports messages with multiple signatures. However, when validating a signed message the API did not indicate which signature was valid, which could potentially lead to confusion. For example, users of the library might mistakenly read protected header values from an attached signature that was different from the one originally validated
O3 Security · Impact-Aware SCA

Is CVE-2016-9122 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2016-9122: square/go-jose.v1 — Fixed in 1.1.0