CVE-2016-9014 is a high-severity (CVSS 8.1) CWE-264 vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django DNS Rebinding Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Django before 1.8.x before 1.8.16, 1.9.x before 1.9.11, and 1.10.x before 1.10.3, when settings.DEBUG is True, allow remote attackers to conduct DNS rebinding attacks by leveraging failure to validate the HTTP Host header against settings.ALLOWED_HOSTS.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 1.8a1&&< 1.8.16 | 1.8.16pip install --upgrade 'django==1.8.16' |
| 🐍PyPI | django | ≥ 1.9a1&&< 1.9.11 | 1.9.11pip install --upgrade 'django==1.9.11' |
| 🐍PyPI | django | ≥ 1.10a1&&< 1.10.3 | 1.10.3pip install --upgrade 'django==1.10.3' |
Affected Products
ubuntu linuxcanonicaldjangodjangoprojectfedorafedoraprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.8.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9014 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-9014 in your dependencies?
Find it across PyPI, including transitive dependencies.