CVE-2016-9013 is a critical-severity (CVSS 9.8) Hard-coded Credentials vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django user with hardcoded password created when running tests on Oracle
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Django 1.8.x before 1.8.16, 1.9.x before 1.9.11, and 1.10.x before 1.10.3 use a hardcoded password for a temporary database user created when running tests with an Oracle database, which makes it easier for remote attackers to obtain access to the database server by leveraging failure to manually specify a password in the database settings TEST dictionary.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 1.10a1&&< 1.10.3 | 1.10.3pip install --upgrade 'django==1.10.3' |
| 🐍PyPI | django | ≥ 1.9a1&&< 1.9.11 | 1.9.11pip install --upgrade 'django==1.9.11' |
| 🐍PyPI | django | ≥ 1.8a1&&< 1.8.16 | 1.8.16pip install --upgrade 'django==1.8.16' |
Affected Products
ubuntu linuxcanonicaldjangodjangoprojectfedorafedoraprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9013 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2016-9013 in your dependencies?
Find it across PyPI, including transitive dependencies.