NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-8746 — ranger-plugins-common

MEDIUMFix: apache/ranger@2fcd7f7

CVE-2016-8746 is a medium-severity (CVSS 5.9) CWE-426 vulnerability in org.apache.ranger:ranger-plugins-common. A fix is available for org.apache.ranger:ranger-plugins-common — see the affected versions and patch details below.

Apache Ranger policy engine incorrectly matches paths in certain conditions

Also known asGHSA-xv7x-x6wr-xx7g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%1.13%2.26%3.39%0.5%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.ranger:ranger-plugins-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Ranger before 0.6.3 policy engine incorrectly matches paths in certain conditions when policy does not contain wildcards and has recursion flag set to true.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.ranger:ranger-plugins-commonall versions0.6.3org.apache.ranger:ranger-plugins-common:0.6.3

Affected Products

1 product · 1 configurations
Application
rangerapache
≤ 0.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.ranger:ranger-plugins-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.ranger:ranger-plugins-common to 0.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-8746 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache Ranger before 0.6.3 policy engine incorrectly matches paths in certain conditions when policy does not contain wildcards and has recursion flag set to true.
O3 Security · Impact-Aware SCA

Is CVE-2016-8746 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-8746: ranger-plugins-common — Fixed in 0.6.3