NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2016-8736 — openmeetings-parent

CRITICAL

CVE-2016-8736 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.apache.openmeetings:openmeetings-parent. A fix is available for org.apache.openmeetings:openmeetings-parent — see the affected versions and patch details below.

Apache OpenMeetings RCE

Also known asGHSA-6cpg-3w7f-j67q
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
4.28%5.07%5.86%6.65%6.1%4.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.openmeetings:openmeetings-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache OpenMeetings before 3.1.2 is vulnerable to Remote Code Execution via RMI deserialization attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.openmeetings:openmeetings-parentall versions3.1.2org.apache.openmeetings:openmeetings-parent:3.1.2

Affected Products

1 product · 1 configurations
Application
openmeetingsapache
< 3.1.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.openmeetings:openmeetings-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.openmeetings:openmeetings-parent to 3.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-8736 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Apache OpenMeetings before 3.1.2 is vulnerable to Remote Code Execution via RMI deserialization attack.
O3 Security · Impact-Aware SCA

Is CVE-2016-8736 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-8736: openmeetings-parent RCE — Fixed in 3.1.2