NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2016-7404 — openstack-magnum

CRITICALFix: openstack/magnum@e93d82e

CVE-2016-7404 is a critical-severity (CVSS 9.8) Information Exposure vulnerability in openstack-magnum. A fix is available for openstack-magnum — see the affected versions and patch details below.

Openstack Magnum Unsafe Credential Handling

Also known asGHSA-793v-r35j-9rp9PYSEC-2026-437
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
1.37%1.71%2.04%2.38%1.9%1.9%1.9%Jul 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍openstack-magnum

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Magnum passes OpenStack credentials into the Heat templates creating its instances. While these should just be used for retrieving the instances' SSL certificates, they allow full API access, though and can be used to perform any API operation the user is authorized to perform.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIopenstack-magnumall versions5.0.0pip install --upgrade 'openstack-magnum==5.0.0'

Affected Products

1 product · 1 configurations
Application
magnumopenstack
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openstack-magnum, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openstack-magnum to 5.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-7404 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

OpenStack Magnum passes OpenStack credentials into the Heat templates creating its instances. While these should just be used for retrieving the instances' SSL certificates, they allow full API access, though and can be used to perform any API operation the user is authorized to perform.
O3 Security · Impact-Aware SCA

Is CVE-2016-7404 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-7404: openstack-magnum — Fixed in 5.0.0