CVE-2016-7151 is a medium-severity (CVSS 5.5) Out-of-bounds Read vulnerability in capstone. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for capstone — see the affected versions and patch details below.
Capstone SEGV caused by a read memory access
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
capstoneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Capstone 3.0.4 has an out-of-bounds vulnerability (SEGV caused by a read memory access) in X86_insn_reg_intel in arch/X86/X86Mapping.c.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | capstone | all versions | 4.0.0pip install --upgrade 'capstone==4.0.0' |
Affected Products
capstonecapstone-engineResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for capstone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update capstone to 4.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-7151 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2016-7151 in your dependencies?
Find it across PyPI, including transitive dependencies.