NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2016-7038 — moodle

HIGH

CVE-2016-7038 is a high-severity (CVSS 7.3) CWE-640 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle Weak Password Recovery Mechanism for Forgotten Password

Also known asGHSA-2phx-w35g-x9vm
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.98%1.47%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In Moodle 2.x and 3.x, web service tokens are not invalidated when the user password is changed or forced to be changed.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 2.7&&< 2.7.162.7.16composer require moodle/moodle:^2.7.16
🐘Packagistmoodle/moodle≥ 2.9&&< 2.9.82.9.8composer require moodle/moodle:^2.9.8
🐘Packagistmoodle/moodle≥ 3.0&&< 3.0.63.0.6composer require moodle/moodle:^3.0.6
🐘Packagistmoodle/moodle≥ 3.1&&< 3.1.23.1.2composer require moodle/moodle:^3.1.2

Affected Products

1 product · 30 configurations
Application
moodlemoodle
≤ 2.7.15
29 versions
2.8.02.8.12.8.22.8.32.8.42.8.52.8.62.8.72.8.82.8.92.8.102.8.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 2.7.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-7038 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Moodle 2.x and 3.x, web service tokens are not invalidated when the user password is changed or forced to be changed.
O3 Security · Impact-Aware SCA

Is CVE-2016-7038 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-7038: moodle — Fixed in 2.7.16