CVE-2016-6814 — groovy
CRITICALCVE-2016-6814 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.codehaus.groovy:groovy. EPSS puts its 30-day exploitation probability at 17.2% (97th percentile). A fix is available for org.codehaus.groovy:groovy — see the affected versions and patch details below.
Deserialization of Untrusted Data in Groovy
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.codehaus.groovy:groovy☕org.codehaus.groovy:groovy-allReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When an application with unsupported Codehaus versions of Groovy from 1.7.0 to 2.4.3, Apache Groovy 2.4.4 to 2.4.7 on classpath uses standard Java serialization mechanisms, e.g. to communicate between servers or to store local data, it was possible for an attacker to bake a special serialized object that will execute code directly when deserialized. All applications which rely on serialization and do not isolate the code which deserializes objects were subject to this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.codehaus.groovy:groovy | ≥ 1.7.0&&< 2.4.8 | 2.4.8org.codehaus.groovy:groovy:2.4.8 |
| ☕Maven | org.codehaus.groovy:groovy-all | ≥ 1.7.0&&< 2.4.8 | 2.4.8org.codehaus.groovy:groovy-all:2.4.8 |
Affected Products
groovyapacheenterprise linux serverredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.codehaus.groovy:groovy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.codehaus.groovy:groovy to 2.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6814 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue affects the versions of groovy as shipped with Red Hat Satellite 6.0 and 6.1. Red Hat Satellite 6.2 and later do not ship groovy, as such they are not affected by this vulnerability.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | groovy-0:1.8.9-8.el7_4 | RHSA-2017:2486 |
| Red Hat JBoss A-MQ 6.3 | see advisory | RHSA-2017:0868 |
| Red Hat JBoss Data Virtualization 6.3 | groovy | RHSA-2017:0272 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-maven33-groovy-0:1.8.9-7.19.el6 | RHSA-2017:2596 |
Frequently Asked Questions
Is CVE-2016-6814 in your dependencies?
Find it across Maven, including transitive dependencies.