CVE-2016-6346 is a high-severity (CVSS 7.5) vulnerability in org.jboss.resteasy:resteasy-jaxrs. A fix is available for org.jboss.resteasy:resteasy-jaxrs — see the affected versions and patch details below.
Denial of service in JBoss resteasy
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jboss.resteasy:resteasy-jaxrsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
RESTEasy enables GZIPInterceptor, which allows remote attackers to cause a denial of service via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jboss.resteasy:resteasy-jaxrs | all versions | 3.0.20.Finalorg.jboss.resteasy:resteasy-jaxrs:3.0.20.Final |
Affected Products
resteasyredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.resteasy:resteasy-jaxrs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jboss.resteasy:resteasy-jaxrs to 3.0.20.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6346 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue was fixed in EAP 7.1.0, but was not fixed in 7.0.7 On Red Hat Satellite 6.5 this issue is fixed through the candlepin package update (candlepin 2.5.8), which contains a non-vulnerable version of RESTEasy.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss BPMS 6.4 | see advisory | RHSA-2017:1675 |
| Red Hat JBoss BRMS 6.4 | see advisory | RHSA-2017:1676 |
| Red Hat JBoss BRMS 7.0 | see advisory | RHSA-2018:2143 |
| Red Hat JBoss EAP 7 | see advisory | RHSA-2018:0003 |
| Red Hat JBoss Enterprise Application Platform 6.4 | see advisory | RHSA-2017:0517 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 | apache-cxf-0:2.7.18-6.SP5_redhat_1.1.ep6.el5 | RHSA-2017:0826 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | apache-cxf-0:2.7.18-6.SP5_redhat_1.1.ep6.el6 | RHSA-2017:0827 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | jboss-ec2-eap-0:7.5.14-2.Final_redhat_2.ep6.el6 | RHSA-2017:0829 |
Frequently Asked Questions
Is CVE-2016-6346 in your dependencies?
Find it across Maven, including transitive dependencies.