NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2016-6233 — zendframework

CRITICAL

CVE-2016-6233 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in zendframework/zendframework. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zendframework/zendframework — see the affected versions and patch details below.

Zend Framework Allows SQL Injection

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
1.22%1.66%2.11%2.55%1.7%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘zendframework/zendframework🐘zendframework/zendframework1

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.19 might allow remote attackers to conduct SQL injection attacks via vectors related to use of the character pattern [\w]* in a regular expression.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzendframework/zendframeworkall versions1.12.19composer require zendframework/zendframework:^1.12.19
🐘Packagistzendframework/zendframework1all versions1.12.19composer require zendframework/zendframework1:^1.12.19

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
3 versions
232425
Application
zend frameworkzend
≤ 1.12.19
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zendframework/zendframework to 1.12.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6233 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.19 might allow remote attackers to conduct SQL injection attacks via vectors related to use of the character pattern `[\w]*` in a regular expression.
O3 Security · Impact-Aware SCA

Is CVE-2016-6233 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-6233: zendframework — Fixed in 1.12.19