NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2016-6186 — django

MEDIUMFix: django/django@d03bf6f

CVE-2016-6186 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in django. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.

Django Cross-site scripting Vulnerability

Also known asGHSA-c8c8-9472-w52hPYSEC-2016-2
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
2.29%8.06%13.8%19.6%13.1%5.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjectLookups.js in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.8.14pip install --upgrade 'django==1.8.14'
🐍PyPIdjango≥ 1.9&&< 1.9.81.9.8pip install --upgrade 'django==1.9.8'
🐍PyPIdjango≥ 1.10a1&&< 1.10rc11.10rc1pip install --upgrade 'django==1.10rc1'

Affected Products

2 products · 13 configurations
OS
debian linuxdebian
1 version
8.0
Application
djangodjangoproject
≤ 1.8.13
10 versions
1.91.9.01.9.11.9.21.9.31.9.41.9.51.9.61.9.71.10
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-40129webappspython✓ Verified

Django CMS 3.3.0 - Editor Snippet Persistent Cross-Site Scripting

by Vulnerability-Lab · Jul 20, 2016

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.8.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6186 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7python-django-0:1.8.14-1.el7ostRHSA-2016:1595
Red Hat OpenStack Platform 8.0 (Liberty)python-django-0:1.8.14-1.el7ostRHSA-2016:1596
Red Hat OpenStack Platform 8.0 Operational Tools for RHEL 7python-django-0:1.8.14-1.el7ostRHSA-2016:1594

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjectLookups.js in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.
O3 Security · Impact-Aware SCA

Is CVE-2016-6186 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-6186: django XSS — Fixed in 1.8.14