NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-5851 — python-docx

HIGHFix: python-openxml/python-docx@61b40b1

CVE-2016-5851 is a high-severity (CVSS 8.8) XML External Entity (XXE) vulnerability in python-docx. A fix is available for python-docx — see the affected versions and patch details below.

Improper Restriction of XML External Entity Reference in python-docx

Also known asGHSA-34wj-p5jm-2p96PYSEC-2016-21
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.40%1.22%2.04%2.85%0.9%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍python-docx

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

python-docx before 0.8.6 allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted document.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpython-docxall versions0.8.6pip install --upgrade 'python-docx==0.8.6'

Affected Products

1 product · 1 configurations
Application
python-docxpython-openxml_project
≤ 0.8.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-docx, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update python-docx to 0.8.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-5851 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

python-docx before 0.8.6 allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted document.
O3 Security · Impact-Aware SCA

Is CVE-2016-5851 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-5851: python-docx XXE — Fixed in 0.8.6