NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2016-4861 — zendframework

CRITICAL

CVE-2016-4861 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in zendframework/zendframework. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zendframework/zendframework — see the affected versions and patch details below.

Zend Framework Allows SQL Injection

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
3.48%3.86%4.24%4.62%4.0%4.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘zendframework/zendframework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.20 might allow remote attackers to conduct SQL injection attacks by leveraging failure to remove comments from an SQL statement before validation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzendframework/zendframeworkall versions1.12.20composer require zendframework/zendframework:^1.12.20

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
3 versions
232425
Application
zend frameworkzend
≤ 1.12.19
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zendframework/zendframework to 1.12.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4861 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.20 might allow remote attackers to conduct SQL injection attacks by leveraging failure to remove comments from an SQL statement before validation.
O3 Security · Impact-Aware SCA

Is CVE-2016-4861 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-4861: zendframework — Fixed in 1.12.20