NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-4041 — plone

HIGH

CVE-2016-4041 is a high-severity (CVSS 7.3) CWE-264 vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.

Plone vulnerable to privilege escalation in WebDAV

Also known asGHSA-qqgj-22gr-73vxPYSEC-2017-55
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.66%1.33%1.99%0.4%1.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍plone🐍plone🐍plone

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Plone 4.0 through 5.1a1 does not have security declarations for Dexterity content-related WebDAV requests, which allows remote attackers to gain webdav access via unspecified vectors.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIplone≥ 3.3&&< 4.3.104.3.10pip install --upgrade 'plone==4.3.10'
🐍PyPIplone≥ 5.0&&< 5.0.55.0.5pip install --upgrade 'plone==5.0.5'
🐍PyPIplone≥ 5.1a1&&< 5.1a25.1a2pip install --upgrade 'plone==5.1a2'

Affected Products

1 product · 44 configurations
Application
ploneplone
40 versions
4.04.0.14.0.24.0.34.0.44.0.54.0.74.0.84.0.94.0.104.14.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update plone to 4.3.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4041 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Plone 4.0 through 5.1a1 does not have security declarations for Dexterity content-related WebDAV requests, which allows remote attackers to gain webdav access via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2016-4041 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-4041: plone — Fixed in 4.3.10