NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2016-3733 — moodle

MEDIUMFix: moodle/moodle@12c2857

CVE-2016-3733 is a medium-severity (CVSS 4.3) CWE-284 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle Improper Access Control

Also known asGHSA-gr8j-qm8r-rfgg
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.56%1.11%1.67%0.4%1.2%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The "restore teacher" feature in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to overwrite the course idnumber.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 2.7&&< 2.7.142.7.14composer require moodle/moodle:^2.7.14
🐘Packagistmoodle/moodle≥ 2.8&&< 2.8.122.8.12composer require moodle/moodle:^2.8.12
🐘Packagistmoodle/moodle≥ 2.9&&< 2.9.62.9.6composer require moodle/moodle:^2.9.6
🐘Packagistmoodle/moodle≥ 3.0&&< 3.0.43.0.4composer require moodle/moodle:^3.0.4

Affected Products

1 product · 44 configurations
Application
moodlemoodle
36 versions
2.7.02.7.12.7.22.7.32.7.42.7.52.7.62.7.72.7.82.7.92.7.102.7.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 2.7.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3733 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

The "restore teacher" feature in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to overwrite the course idnumber.
O3 Security · Impact-Aware SCA

Is CVE-2016-3733 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-3733: moodle — Fixed in 2.7.14