CVE-2016-3729 — moodle
MEDIUMCVE-2016-3729 is a medium-severity (CVSS 6.5) CWE-284 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle Improper Access Control
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The user editing form in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to edit profile fields locked by the administrator.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.0&&< 3.0.3 | 3.0.3composer require moodle/moodle:^3.0.3 |
| 🐘Packagist | moodle/moodle | ≥ 2.9&&< 2.9.6 | 2.9.6composer require moodle/moodle:^2.9.6 |
| 🐘Packagist | moodle/moodle | ≥ 2.8&&< 2.8.12 | 2.8.12composer require moodle/moodle:^2.8.12 |
| 🐘Packagist | moodle/moodle | ≥ 2.7&&< 2.7.14 | 2.7.14composer require moodle/moodle:^2.7.14 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3729 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2016-3729 in your dependencies?
Find it across Packagist, including transitive dependencies.