NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2016-3086 — hadoop-yarn-server-nodema…

CRITICAL

CVE-2016-3086 is a critical-severity (CVSS 9.8) Information Exposure vulnerability in org.apache.hadoop:hadoop-yarn-server-nodemanager. A fix is available for org.apache.hadoop:hadoop-yarn-server-nodemanager — see the affected versions and patch details below.

Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop

Also known asGHSA-895m-ww55-59vw
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%1.54%3.08%4.62%0.4%3.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.hadoop:hadoop-yarn-server-nodemanager☕org.apache.hadoop:hadoop-yarn-server-nodemanager

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The YARN NodeManager in Apache Hadoop 2.6.x before 2.6.5 and 2.7.x before 2.7.3 can leak the password for credential store provider used by the NodeManager to YARN Applications.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.hadoop:hadoop-yarn-server-nodemanager≥ 2.6.0&&< 2.6.52.6.5org.apache.hadoop:hadoop-yarn-server-nodemanager:2.6.5
☕Mavenorg.apache.hadoop:hadoop-yarn-server-nodemanager≥ 2.7.0&&< 2.7.32.7.3org.apache.hadoop:hadoop-yarn-server-nodemanager:2.7.3

Affected Products

1 product · 8 configurations
Application
hadoopapache
8 versions
2.6.02.6.12.6.22.6.32.6.42.7.02.7.12.7.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-yarn-server-nodemanager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.hadoop:hadoop-yarn-server-nodemanager to 2.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3086 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

The YARN NodeManager in Apache Hadoop 2.6.x before 2.6.5 and 2.7.x before 2.7.3 can leak the password for credential store provider used by the NodeManager to YARN Applications.
O3 Security · Impact-Aware SCA

Is CVE-2016-3086 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-3086: hadoop-yarn-server — Fixed in 2.6.5