CVE-2016-3082 — struts2-core
CRITICALCVE-2016-3082 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in org.apache.struts:struts2-core. EPSS puts its 30-day exploitation probability at 19.2% (97th percentile). A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.
Remote Code Execution in Apache Struts
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.struts:struts2-core☕org.apache.struts:struts2-core☕org.apache.struts:struts2-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
XSLTResult in Apache Struts 2.x before 2.3.20.2, 2.3.24.x before 2.3.24.2, and 2.3.28.x before 2.3.28.1 allows remote attackers to execute arbitrary code via the stylesheet location parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.struts:struts2-core | all versions | 2.3.20.3org.apache.struts:struts2-core:2.3.20.3 |
| ☕Maven | org.apache.struts:struts2-core | ≥ 2.3.24&&< 2.3.24.3 | 2.3.24.3org.apache.struts:struts2-core:2.3.24.3 |
| ☕Maven | org.apache.struts:struts2-core | ≥ 2.3.28&&< 2.3.28.1 | 2.3.28.1org.apache.struts:struts2-core:2.3.28.1 |
Affected Products
strutsapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.struts:struts2-core to 2.3.20.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3082 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-3082 in your dependencies?
Find it across Maven, including transitive dependencies.