NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

CVE-2016-2513 — django

LOWFix: django/django@67b46ba

CVE-2016-2513 is a low-severity (CVSS 3.1) Information Exposure vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django User Enumeration Vulnerability

Also known asGHSA-fp6p-5xvw-m74fPYSEC-2016-16
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.62%1.74%2.86%3.97%1.3%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The password hasher in contrib/auth/hashers.py in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to enumerate users via a timing attack involving login requests.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.8.10pip install --upgrade 'django==1.8.10'
🐍PyPIdjango≥ 1.9&&< 1.9.31.9.3pip install --upgrade 'django==1.9.3'

Affected Products

1 product · 4 configurations
Application
djangodjangoproject
4 versions
1.8.91.91.9.11.9.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.8.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2513 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6python-django-0:1.6.11-5.el6ostRHSA-2016:0502
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7python-django-0:1.6.11-5.el7ostRHSA-2016:0506
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7python-django-0:1.6.11-5.el7ostRHSA-2016:0505
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7python-django-0:1.8.11-1.el7ostRHSA-2016:0504
Red Hat Enterprise Linux OpenStack Platform 7.0 Operational Tools for RHEL 7python-django-0:1.6.11-5.el7ostRHSA-2016:0503

Frequently Asked Questions

The password hasher in contrib/auth/hashers.py in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to enumerate users via a timing attack involving login requests.
O3 Security · Impact-Aware SCA

Is CVE-2016-2513 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-2513: django — Fixed in 1.8.10