NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-2512 — django

HIGHFix: django/django@c5544d2

CVE-2016-2512 is a high-severity (CVSS 7.4) Cross-site Scripting (XSS) vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django XSS Vulnerability

Also known asGHSA-pw27-w7w4-9qc7PYSEC-2016-15
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.35%1.87%3.39%4.91%1.2%4.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The utils.http.is_safe_url function in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks or possibly conduct cross-site scripting (XSS) attacks via a URL containing basic authentication, as demonstrated by http://mysite.example.com\@attacker.com.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.8.10pip install --upgrade 'django==1.8.10'
🐍PyPIdjango≥ 1.9a1&&< 1.9.31.9.3pip install --upgrade 'django==1.9.3'

Affected Products

1 product · 4 configurations
Application
djangodjangoproject
4 versions
1.8.91.91.9.11.9.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.8.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2512 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6python-django-0:1.6.11-5.el6ostRHSA-2016:0502
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7python-django-0:1.6.11-5.el7ostRHSA-2016:0506
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7python-django-0:1.6.11-5.el7ostRHSA-2016:0505
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7python-django-0:1.8.11-1.el7ostRHSA-2016:0504
Red Hat Enterprise Linux OpenStack Platform 7.0 Operational Tools for RHEL 7python-django-0:1.6.11-5.el7ostRHSA-2016:0503

Frequently Asked Questions

The utils.http.is_safe_url function in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks or possibly conduct cross-site scripting (XSS) attacks via a URL containing basic authentication, as demonstrated by http://mysite.example.com\@attacker.com.
O3 Security · Impact-Aware SCA

Is CVE-2016-2512 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-2512: django XSS — Fixed in 1.8.10