NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2016-2510 — bsh

HIGHFix: beanshell/beanshell@1ccc66b

CVE-2016-2510 is a high-severity (CVSS 8.1) CWE-19 vulnerability in org.apache-extras.beanshell:bsh. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache-extras.beanshell:bsh — see the affected versions and patch details below.

Improper Input Validation in BeanShell

Also known asGHSA-gxg6-rc6c-v673
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
70.4%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
29.9%46.5%63.1%79.8%42.9%70.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache-extras.beanshell:bsh

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

BeanShell (bsh) before 2.0b6, when included on the classpath by an application that uses Java serialization or XStream, allows remote attackers to execute arbitrary code via crafted serialized data, related to XThis.Handler.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache-extras.beanshell:bshall versions2.0b6org.apache-extras.beanshell:bsh:2.0b6

Affected Products

3 products · 9 configurations
Application
beanshellbeanshell
2 versions
1.02.0
OS
ubuntu linuxcanonical
3 versions
12.0414.0415.10
OS
debian linuxdebian
2 versions
7.08.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache-extras.beanshell:bsh, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache-extras.beanshell:bsh to 2.0b6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2510 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Fuse 7.3.1camelRHSA-2019:1545
Red Hat JBoss BPMS 6.2see advisoryRHSA-2016:0539
Red Hat JBoss BRMS 6.2see advisoryRHSA-2016:0540
Red Hat JBoss Data Virtualization 6.2bsh2RHSA-2016:1135
Red Hat JBoss Fuse 6.3see advisoryRHSA-2016:2035
Red Hat JBoss SOA Platform 5.3jbossasRHSA-2016:1376

Frequently Asked Questions

BeanShell (bsh) before 2.0b6, when included on the classpath by an application that uses Java serialization or XStream, allows remote attackers to execute arbitrary code via crafted serialized data, related to XThis.Handler.
O3 Security · Impact-Aware SCA

Is CVE-2016-2510 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-2510: bsh RCE — Fixed in 2.0b6