CVE-2016-2141 is a critical-severity (CVSS 9.8) vulnerability in org.jgroups:jgroups. A fix is available for org.jgroups:jgroups — see the affected versions and patch details below.
Improper Input Validation in JGroups
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jgroups:jgroups☕org.jgroups:jgroupsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
It was found that JGroups did not require necessary headers for encrypt and auth protocols from new nodes joining the cluster. An attacker could use this flaw to bypass security restrictions, and use this vulnerability to send and receive messages within the cluster, leading to information disclosure, message spoofing, or further possible attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jgroups:jgroups | ≥ 3.3.0.Alpha1&&< 3.6.10.Final | 3.6.10.Finalorg.jgroups:jgroups:3.6.10.Final |
| ☕Maven | org.jgroups:jgroups | all versions | 3.2.16.Finalorg.jgroups:jgroups:3.2.16.Final |
Affected Products
jboss enterprise application platformredhatjgroupsredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jgroups:jgroups, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jgroups:jgroups to 3.6.10.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2141 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Please refer to https://access.redhat.com/articles/2360521 for more information.Source: Red Hat security advisory for CVE-2016-2141 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| JBoss Enterprise BRMS Platform 5.3 | Clustering | RHSA-2016:1345 |
| Red Hat JBoss BRMS 6.3 | Clustering | RHSA-2016:1347 |
| Red Hat JBoss Data Grid 6.6 | jgroups | RHSA-2016:1334 |
| Red Hat JBoss Data Virtualization 6.2 | Clustering | RHSA-2016:1346 |
| Red Hat JBoss EAP 7.0 | see advisory | RHSA-2016:1333 |
| Red Hat JBoss Enterprise Application Platform 5.2 | see advisory | RHSA-2016:1329 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | jgroups-1:2.6.22-2.ep5.el5 | RHSA-2016:1328 |
| Red Hat JBoss Enterprise Application Platform 6.4 | see advisory | RHSA-2016:1331 |
Frequently Asked Questions
Is CVE-2016-2141 in your dependencies?
Find it across Maven, including transitive dependencies.