CVE-2016-1866 — salt
HIGHCVE-2016-1866 is a high-severity (CVSS 8.1) CWE-284 vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.
Salt Improper Access Control
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
saltReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Salt 2015.8.x before 2015.8.4 does not properly handle clear messages on the minion, which allows man-in-the-middle attackers to execute arbitrary code by inserting packets into the minion-master data stream.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | salt | ≥ 2015.8.0rc1&&< 2015.8.4 | 2015.8.4pip install --upgrade 'salt==2015.8.4' |
Affected Products
leapopensusesaltsaltstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update salt to 2015.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-1866 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2016-1866 in your dependencies?
Find it across PyPI, including transitive dependencies.