CVE-2016-15015 is a medium-severity (CVSS 5.3) CWE-208 vulnerability in barzahlen/barzahlen-php. A fix is available for barzahlen/barzahlen-php — see the affected versions and patch details below.
Barzahlen Payment Module PHP SDK vulnerable to Observable Timing Discrepancy
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
barzahlen/barzahlen-phpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability, which was classified as problematic, was found in viafintech Barzahlen Payment Module PHP SDK up to 2.0.0. Affected is the function verify of the file src/Webhook.php. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 2.0.1 is able to address this issue. The patch is identified as 3e7d29dc0ca6c054a6d6e211f32dae89078594c1. It is recommended to upgrade the affected component. VDB-217650 is the identifier assigned to this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | barzahlen/barzahlen-php | all versions | 2.0.1composer require barzahlen/barzahlen-php:^2.0.1 |
Affected Products
barzahlen payment module php sdkpaysafeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for barzahlen/barzahlen-php, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update barzahlen/barzahlen-php to 2.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-15015 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-15015 in your dependencies?
Find it across Packagist, including transitive dependencies.