NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2016-1494 — rsa

MEDIUMFix: sybrenstuvel/python-rsa@ab5d21c

CVE-2016-1494 is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in rsa. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for rsa — see the affected versions and patch details below.

Python RSA allows attackers to spoof signatures

Also known asGHSA-8rjr-6qq5-pj9pPYSEC-2016-10
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
1.96%4.05%6.14%8.23%3.1%7.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍rsa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIrsaall versions3.3pip install --upgrade 'rsa==3.3'

Affected Products

4 products · 6 configurations
OS
fedorafedoraproject
2 versions
2223
OS
leapopensuse
1 version
42.1
OS
opensuseopensuse
2 versions
13.113.2
Application
rsapython
< 3.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rsa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rsa to 3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-1494 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.
O3 Security · Impact-Aware SCA

Is CVE-2016-1494 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-1494: rsa — Fixed in 3.3