NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2016-10744 — select2

MEDIUMFix: snipe/snipe-it#6831

CVE-2016-10744 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in select2. A fix is available for select2 — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Select2

Also known asGHSA-rf66-hmqf-q3fc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.37%1.14%1.91%2.68%0.9%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

614other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
select2npm
955Kdownloads / week

Description

In Select2 through 4.0.5, as used in Snipe-IT and other products, rich selectlists allow XSS. This affects use cases with Ajax remote data loading when HTML templates are used to display listbox data.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmselect2all versions4.0.6npm install select2@4.0.6

Affected Products

1 product · 1 configurations
Application
select2select2
≤ 4.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for select2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update select2 to 4.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10744 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Select2 through 4.0.5, as used in Snipe-IT and other products, rich selectlists allow XSS. This affects use cases with Ajax remote data loading when HTML templates are used to display listbox data.
O3 Security · Impact-Aware SCA

Is CVE-2016-10744 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2016-10744: select2 XSS — Fixed in 4.0.6