Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
CISA KEV · ACTIVELY EXPLOITED
CRITICAL severity

CVE-2016-10033 — phpmailer

CRITICAL

CVE-2016-10033 is a critical-severity (CVSS 9.8) CWE-88 vulnerability in phpmailer/phpmailer. It is in CISA's Known Exploited Vulnerabilities catalog (added 2025-07-07) — treat it as actively exploited and patch now. A fix is available for phpmailer/phpmailer — see the affected versions and patch details below.

Remote code execution in PHPMailer

Also known asGHSA-5f37-gxvh-23v6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
37 known
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2025-07-07. Federal agencies were required to remediate by 2025-07-28.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2016-10033.

EPSS Exploitation Probability

via FIRST.org ↗
99.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
92.9%95.2%97.6%100.0%94.5%99.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2016-10033 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 396,966 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

1 pkg affected
🐘phpmailer/phpmailer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The mailSend function in the default isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a " (backslash double quote) in a crafted Sender property.

Patches

Fixed in 5.2.18

Workarounds

Filter and validate user input before passing it to internal functions.

References

https://nvd.nist.gov/vuln/detail/CVE-2016-10033 Related to a follow-on issue in https://nvd.nist.gov/vuln/detail/CVE-2016-10045

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmailer/phpmailer≥ 5.0.0&&< 5.2.185.2.18composer require phpmailer/phpmailer:^5.2.18

Affected Products

3 products · 3 configurations
Application
joomla\!joomla
≥ 1.5.0 && ≤ 3.6.5
range
Application
phpmailerphpmailer_project
< 5.2.18
range
Application
wordpresswordpress
≤ 4.7
range
Exploits & PoCs
37

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-40986webappsphp

PHPMailer < 5.2.20 / SwiftMailer < 5.4.5-DEV / Zend Framework / zend-mail < 2.4.11 - 'AIO' 'PwnScriptum' Remote Code Execution

by Dawid Golunski · Jan 2, 2017

EDB-42024remotephp✓ Verified

WordPress Plugin PHPMailer 4.6 - Host Header Command Injection (Metasploit)

by Metasploit · May 17, 2017

EDB-40970webappsphp

PHPMailer < 5.2.18 - Remote Code Execution

by Dawid Golunski · Dec 25, 2016

EDB-41996remotephp

Vanilla Forums < 2.3 - Remote Code Execution

by Dawid Golunski · May 11, 2017

EDB-40974webappsphp

PHPMailer < 5.2.18 - Remote Code Execution

by anarc0der · Dec 29, 2016

EDB-40969webappsphp

PHPMailer < 5.2.20 - Remote Code Execution

by Dawid Golunski · Dec 27, 2016

EDB-42221webappsphp

PHPMailer < 5.2.20 with Exim MTA - Remote Code Execution

by phackt_ul · Jun 21, 2017

EDB-41962webappslinux

WordPress Core 4.6 - Remote Code Execution

by Dawid Golunski · May 3, 2017

EDB-40968webappsphp✓ Verified

PHPMailer < 5.2.18 - Remote Code Execution

by Dawid Golunski · Dec 26, 2016

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmailer/phpmailer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmailer/phpmailer to 5.2.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10033 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2016-10033

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2016-10033 -u https://target
Template
WordPress PHPMailer < 5.2.18 - Remote Code Execution
Severity
critical
Impact
Successful exploitation of this vulnerability can lead to unauthorized remote code execution on the affected WordPress website.
Remediation
Upgrade PHPMailer to version 5.2.18 or higher to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (princechaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact The `mailSend` function in the default `isMail` transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \&quot; (backslash double quote) in a crafted `Sender` property. ### Patches Fixed in 5.2.18 ### Workarounds Filter and validate user input before passing it to internal functions. ### References https://nvd.nist.gov/vuln/detail/CVE-2016-10033 Related to a follow-on issue in https://nvd.nist.gov/vuln/detail/CVE-2016-10045 ### For more information If you have any questions or co
O3 Security · Impact-Aware SCA

Is CVE-2016-10033 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-10033: phpmailer RCE (Critical 9.8, KEV)