NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2016-1000229 — swagger-ui

MEDIUM

CVE-2016-1000229 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in swagger-ui. A fix is available for swagger-ui — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in swagger-ui

Also known asGHSA-h8wp-wgcq-qhrf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
3.43%4.51%5.60%6.68%6.1%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

167other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
swagger-uinpm
170Kdownloads / week

Description

swagger-ui has XSS in key names

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmswagger-uiall versions2.2.1npm install swagger-ui@2.2.1

Affected Products

3 products · 3 configurations
Application
jboss fuseredhat
1 version
6.3
Application
openshiftredhat
1 version
2.0
Application
swagger-uismartbear
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swagger-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update swagger-ui to 2.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-1000229 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

swagger-ui has XSS in key names
O3 Security · Impact-Aware SCA

Is CVE-2016-1000229 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2016-1000229: swagger-ui XSS — Fixed in 2.2.1