NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2016-0792 — jenkins-core

HIGHFix: jenkinsci/jenkins@7f202f0

CVE-2016-0792 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in org.jenkins-ci.main:jenkins-core. 10 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Jenkins allows Deserialization of Untrusted Data via an XML File

Also known asGHSA-45rg-g72w-r393
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
10 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
83.3%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
80.3%84.6%88.9%93.3%90.9%83.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow remote authenticated users to execute arbitrary code via serialized data in an XML file, related to XStream and groovy.util.Expando.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 1.643&&< 1.6501.650org.jenkins-ci.main:jenkins-core:1.650
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions1.642.2org.jenkins-ci.main:jenkins-core:1.642.2

Affected Products

2 products · 3 configurations
Application
jenkinsjenkins
≤ 1.642.1
range
Application
openshiftredhat
1 version
3.1
Exploits & PoCs
10

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-42394remotejava✓ Verified

Jenkins < 1.650 - Java Deserialization

by Janusz Piechówka · Jul 30, 2017

EDB-43375remotemultiple✓ Verified

Jenkins - XStream Groovy classpath Deserialization (Metasploit)

by Metasploit · Dec 19, 2017

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 1.650 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0792 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift Enterprise 2.2activemq-0:5.9.0-6.redhat.611463.el6opRHSA-2016:1773
Red Hat OpenShift Enterprise 3.1jenkins-0:1.642.2-1.el7RHSA-2016:0711

Frequently Asked Questions

Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow remote authenticated users to execute arbitrary code via serialized data in an XML file, related to XStream and groovy.util.Expando.
O3 Security · Impact-Aware SCA

Is CVE-2016-0792 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-0792: jenkins-core RCE — Fixed in 1.650