NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-0789 — jenkins-core

MEDIUMFix: jenkinsci/jenkins@f5c51fb

CVE-2016-0789 is a medium-severity (CVSS 6.1) Improper Input Validation vulnerability in org.jenkins-ci.main:jenkins-core. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Jenkins has CRLF Injection Vulnerability in the CLI

Also known asGHSA-8p3c-m625-wh83
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.76%1.53%2.29%0.1%1.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

CRLF injection vulnerability in the CLI command documentation in Jenkins before 1.650 and LTS before 1.642.2 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 1.643&&< 1.6501.650org.jenkins-ci.main:jenkins-core:1.650
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions1.642.2org.jenkins-ci.main:jenkins-core:1.642.2

Affected Products

2 products · 3 configurations
Application
jenkinsjenkins
≤ 1.649
range
Application
openshiftredhat
1 version
3.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 1.650 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0789 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Enterprise 2.2activemq-0:5.9.0-6.redhat.611463.el6opRHSA-2016:1773
Red Hat OpenShift Enterprise 3.1jenkins-0:1.642.2-1.el7RHSA-2016:0711

Frequently Asked Questions

CRLF injection vulnerability in the CLI command documentation in Jenkins before 1.650 and LTS before 1.642.2 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2016-0789 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-0789: jenkins-core — Fixed in 1.650