CVE-2016-0763 is a medium-severity (CVSS 6.3) CWE-264 vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 11.3% (96th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Verification of Source of a Communication Channel in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2016-0763.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The setGlobalContext method in org/apache/naming/factory/ResourceLinkFactory.java in Apache Tomcat 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M3 does not consider whether ResourceLinkFactory.setGlobalContext callers are authorized, which allows remote authenticated users to bypass intended SecurityManager restrictions and read or write to arbitrary application data, or cause a denial of service (application disruption), via a web application that sets a crafted global context.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.68 | 7.0.68org.apache.tomcat:tomcat:7.0.68 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0&&< 8.0.32 | 8.0.32org.apache.tomcat:tomcat:8.0.32 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0M1&&< 9.0.0.M3 | 9.0.0.M3org.apache.tomcat:tomcat:9.0.0.M3 |
Affected Products
tomcatapacheubuntu linuxcanonicaldebian linuxdebianDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 7.0.68 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0763 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.69-10.el7 | RHSA-2016:2599 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 6 | tomcat7-0:7.0.54-23_patch_05.ep6.el6 | RHSA-2016:2807 |
| Red Hat JBoss Web Server 2.1 | tomcat7 | RHSA-2016:2808 |
| Red Hat JBoss Web Server 3.0 | see advisory | RHSA-2016:1089 |
| Red Hat JBoss Web Server 3 for RHEL 6 | httpd24-0:2.4.6-61.ep7.el6 | RHSA-2016:1087 |
| Red Hat JBoss Web Server 3 for RHEL 7 | httpd24-0:2.4.6-61.ep7.el7 | RHSA-2016:1088 |
Frequently Asked Questions
Is CVE-2016-0763 in your dependencies?
Find it across Maven, including transitive dependencies.