NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2016-0724 — moodle

MEDIUMFix: moodle/moodle@4323a97

CVE-2016-0724 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle sensitive information disclosure

Also known asGHSA-hjrj-7wcj-7j3c
Published
Updated
Affected
5 pkgs
Patched
4 / 5
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.08%0.87%1.65%2.44%0.6%1.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The (1) core_enrol_get_course_enrolment_methods and (2) enrol_self_get_instance_info web services in Moodle through 2.6.11, 2.7.x before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 do not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to obtain sensitive information via a web-service request.

Affected Packages

5 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versionsNo fix
🐘Packagistmoodle/moodle≥ 2.7.0&&< 2.7.122.7.12composer require moodle/moodle:^2.7.12
🐘Packagistmoodle/moodle≥ 2.8.0&&< 2.8.102.8.10composer require moodle/moodle:^2.8.10
🐘Packagistmoodle/moodle≥ 2.9.0&&< 2.9.42.9.4composer require moodle/moodle:^2.9.4
🐘Packagistmoodle/moodle≥ 3.0.0&&< 3.0.23.0.2composer require moodle/moodle:^3.0.2

Affected Products

2 products · 31 configurations
OS
fedorafedoraproject
2 versions
2223
Application
moodlemoodle
≤ 2.6.11
28 versions
2.7.02.7.12.7.22.7.32.7.42.7.52.7.62.7.72.7.82.7.92.7.102.7.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2016-0724; check the affected-versions list above or the advisory for the patched release of moodle/moodle, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

The (1) core_enrol_get_course_enrolment_methods and (2) enrol_self_get_instance_info web services in Moodle through 2.6.11, 2.7.x before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 do not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to obtain sensitive information via a web-service request.
O3 Security · Impact-Aware SCA

Is CVE-2016-0724 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-0724: moodle Info Disclosure — Fixed in 2.7.12