NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2015-8796 — solr

MEDIUMFix: apache/lucene@dc2f229

CVE-2015-8796 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.solr:solr. A fix is available for org.apache.solr:solr — see the affected versions and patch details below.

Apache Solr Cross-site scripting Vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
2.05%2.64%3.23%3.82%2.6%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.solr:solr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in webapp/web/js/scripts/schema-browser.js in the Admin UI in Apache Solr before 5.3 allows remote attackers to inject arbitrary web script or HTML via a crafted schema-browse URL.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.solr:solrall versions5.3org.apache.solr:solr:5.3

Affected Products

1 product · 1 configurations
Application
solrapache
≤ 5.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.solr:solr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.solr:solr to 5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8796 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in `webapp/web/js/scripts/schema-browser.js` in the Admin UI in Apache Solr before 5.3 allows remote attackers to inject arbitrary web script or HTML via a crafted schema-browse URL.
O3 Security · Impact-Aware SCA

Is CVE-2015-8796 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-8796: solr XSS — Fixed in 5.3