CVE-2015-8213 is a low-severity (CVSS 2.8) Information Exposure vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django settings leak in date template filter
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The get_format function in utils/formats.py in Django before 1.7.x before 1.7.11, 1.8.x before 1.8.7, and 1.9.x before 1.9rc2 might allow remote attackers to obtain sensitive application secrets via a settings key in place of a date/time format setting, as demonstrated by SECRET_KEY.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 1.7&&< 1.7.11 | 1.7.11pip install --upgrade 'django==1.7.11' |
| 🐍PyPI | django | ≥ 1.8a1&&< 1.8.7 | 1.8.7pip install --upgrade 'django==1.8.7' |
| 🐍PyPI | django | ≥ 1.9a1&&< 1.9rc2 | 1.9rc2pip install --upgrade 'django==1.9rc2' |
Affected Products
djangodjangoprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.7.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8213 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | python-django-0:1.6.11-4.el6ost | RHSA-2016:0158 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | python-django-0:1.6.11-4.el7ost | RHSA-2016:0157 |
| Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 | python-django-0:1.6.11-4.el7ost | RHSA-2016:0129 |
| Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 | python-django-0:1.8.7-1.el7 | RHSA-2016:0156 |
| Red Hat Enterprise Linux OpenStack Platform 7.0 Operational Tools for RHEL 7 | python-django-0:1.6.11-4.el7ost | RHSA-2016:0360 |
Frequently Asked Questions
Is CVE-2015-8213 in your dependencies?
Find it across PyPI, including transitive dependencies.