NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2015-8103 — cli

CRITICALFix: jenkinsci/jenkins@5bd9b55

CVE-2015-8103 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.jenkins-ci.main:cli. 8 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jenkins-ci.main:cli — see the affected versions and patch details below.

Jenkins CLI Deserialization of Untrusted Data vulnerability

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
8 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
91.9%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
84.7%87.6%90.6%93.5%90.4%91.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:cli☕org.jenkins-ci.main:cli

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic webapps/ROOT/WEB-INF/lib/commons-collections-*.jar file and the "Groovy variant in ysoserial".

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:cliall versions1.625.2org.jenkins-ci.main:cli:1.625.2
☕Mavenorg.jenkins-ci.main:cli≥ 1.626&&< 1.6381.638org.jenkins-ci.main:cli:1.638

Affected Products

2 products · 4 configurations
Application
jenkinsjenkins
< 1.638
range
Application
openshift container platformredhat
2 versions
2.23.1
Exploits & PoCs
8

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-38983remotejava✓ Verified

Jenkins CLI - RMI Java Deserialization (Metasploit)

by Metasploit · Dec 15, 2015

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:cli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:cli to 1.625.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8103 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
Workaround published by Red Hat
https://jenkins-ci.org/content/mitigating-unauthenticated-remote-code-execution-0-day-jenkins-cli
Source: Red Hat security advisory for CVE-2015-8103 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat OpenShift Enterprise 2.2activemq-0:5.9.0-6.redhat.611454.el6opRHSA-2016:0489
Red Hat OpenShift Enterprise 3.1atomic-openshift-0:3.1.1.6-1.git.0.b57e8bd.el7aosRHSA-2016:0070

Frequently Asked Questions

The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic `webapps/ROOT/WEB-INF/lib/commons-collections-*.jar` file and the "Groovy variant in `ysoserial`".
O3 Security · Impact-Aware SCA

Is CVE-2015-8103 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-8103: cli RCE — Fixed in 1.625.2