NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2015-7562 — teampass

MEDIUMFix: nilsteampassnet/TeamPass#1140

CVE-2015-7562 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in nilsteampassnet/teampass. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nilsteampassnet/teampass — see the affected versions and patch details below.

TeamPass vulnerable to Cross-site Scripting

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.28%0.96%1.65%2.33%1.0%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nilsteampassnet/teampass

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in TeamPass 2.1.24 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) label value of an item or (2) name of a role.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnilsteampassnet/teampassall versions2.1.25composer require nilsteampassnet/teampass:^2.1.25

Affected Products

1 product · 1 configurations
Application
teampassteampass
≤ 2.1.24
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-39559webappsphp✓ Verified

TeamPass 2.1.24 - Multiple Vulnerabilities

by Vincent Malguy · Mar 14, 2016

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nilsteampassnet/teampass, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nilsteampassnet/teampass to 2.1.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7562 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in TeamPass 2.1.24 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) label value of an item or (2) name of a role.
O3 Security · Impact-Aware SCA

Is CVE-2015-7562 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-7562: teampass XSS — Fixed in 2.1.25