CVE-2015-7503 — zendframework
HIGHCVE-2015-7503 is a high-severity (CVSS 7.5) CWE-320 vulnerability in zendframework/zendframework. A fix is available for zendframework/zendframework — see the affected versions and patch details below.
Zend Framework Information Disclosure
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zendframework/zendframework🐘zendframework/zend-crypt🐘zendframework/zend-crypt🐘zendframework/zendframeworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA private key.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework | ≥ 2.5.0&&< 2.5.2 | 2.5.2composer require zendframework/zendframework:^2.5.2 |
| 🐘Packagist | zendframework/zend-crypt | ≥ 2.0.0&&< 2.4.9 | 2.4.9composer require zendframework/zend-crypt:^2.4.9 |
| 🐘Packagist | zendframework/zend-crypt | ≥ 2.5.0&&< 2.5.2 | 2.5.2composer require zendframework/zend-crypt:^2.5.2 |
| 🐘Packagist | zendframework/zendframework | ≥ 2.0.0&&< 2.4.9 | 2.4.9composer require zendframework/zendframework:^2.4.9 |
Affected Products
zend frameworkzendDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework to 2.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7503 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-7503 in your dependencies?
Find it across Packagist, including transitive dependencies.