CVE-2015-7318 — plone
HIGHCVE-2015-7318 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.
Plone Header Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | ≥ 3.3&&< 4.0a1 | 4.0a1pip install --upgrade 'plone==4.0a1' |
Affected Products
ploneploneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 4.0a1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7318 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-7318 in your dependencies?
Find it across PyPI, including transitive dependencies.