CVE-2015-7316 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.
Plone Cross-site Scripting Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
plone🐍plone🐍plone🐍plone🐍plone🐍ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Plone's URL checking infrastructure includes a method for checking if URLs valid and located in the Plone site. By passing HTML into a specially crafted url containing <script, %3Cscript, javascript:, or javascript%3A, Cross-site Scripting can be achieved.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | ≥ 3.3&&< 3.3.7 | 3.3.7pip install --upgrade 'plone==3.3.7' |
| 🐍PyPI | plone | ≥ 4.0&&< 4.0.11 | 4.0.11pip install --upgrade 'plone==4.0.11' |
| 🐍PyPI | plone | ≥ 4.1&&< 4.1.7 | 4.1.7pip install --upgrade 'plone==4.1.7' |
| 🐍PyPI | plone | ≥ 4.2&&< 4.2.8 | 4.2.8pip install --upgrade 'plone==4.2.8' |
| 🐍PyPI | plone | ≥ 4.3&&< 4.3.7 | 4.3.7pip install --upgrade 'plone==4.3.7' |
| 🐍PyPI | plone | all versions | No fix |
Affected Products
ploneploneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 3.3.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7316 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2015-7316 in your dependencies?
Find it across PyPI, including transitive dependencies.