CVE-2015-7315 is a medium-severity (CVSS 5.9) CWE-284 vulnerability in products-cmfplone. A fix is available for products-cmfplone — see the affected versions and patch details below.
Plone unauthorized member addition vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
products-cmfplone🐍products-cmfplone🐍plone🐍plone🐍plone🐍plone🐍plone🐍ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Plone 3.3.0 through 3.3.6, 4.0.0 through 4.0.10, 4.1.0 through 4.1.6, 4.2.0 through 4.2.7, 4.3.0 through 4.3.6, and 5.0rc1 allows remote attackers to add a new member to a Plone site with registration enabled, without acknowledgment of site administrator.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | products-cmfplone | ≥ 3.3.0&&< 4.3.7 | 4.3.7pip install --upgrade 'products-cmfplone==4.3.7' |
| 🐍PyPI | products-cmfplone | ≥ 5.0a1&&< 5.0rc2 | 5.0rc2pip install --upgrade 'products-cmfplone==5.0rc2' |
| 🐍PyPI | plone | ≥ 3.3 | No fix |
| 🐍PyPI | plone | ≥ 4.0a1 | No fix |
| 🐍PyPI | plone | ≥ 4.1a1 | No fix |
| 🐍PyPI | plone | ≥ 4.2a1 | No fix |
Affected Products
ploneploneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for products-cmfplone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update products-cmfplone to 4.3.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7315 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2015-7315 in your dependencies?
Find it across PyPI, including transitive dependencies.