CVE-2015-7293 — plone
HIGHCVE-2015-7293 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in plone. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for plone — see the affected versions and patch details below.
Plone vulnerable to cross-site request forgery
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site request forgery (CSRF) vulnerabilities in Zope Management Interface 4.3.7 and earlier, and Plone before 5.x.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | all versions | 5.0a1pip install --upgrade 'plone==5.0a1' |
Affected Products
ploneplonezope management interfacezopeResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Zope Management Interface 4.3.7 - Cross-Site Request Forgery
by hyp3rlinx · Oct 7, 2015
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 5.0a1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7293 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-7293 in your dependencies?
Find it across PyPI, including transitive dependencies.