CVE-2015-5351 — tomcat
HIGHCVE-2015-5351 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Apache Tomcat allows remote attackers to bypass a CSRF protection mechanism by using a token
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2015-5351.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The (1) Manager and (2) Host Manager applications in Apache Tomcat 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M2 establish sessions and send CSRF tokens for arbitrary new requests, which allows remote attackers to bypass a CSRF protection mechanism by using a token.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | all versions | 7.0.68org.apache.tomcat:tomcat:7.0.68 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0&&< 8.0.31 | 8.0.31org.apache.tomcat:tomcat:8.0.31 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0.M0&&< 9.0.0.M2 | 9.0.0.M2org.apache.tomcat:tomcat:9.0.0.M2 |
Affected Products
tomcatapacheubuntu linuxcanonicaldebian linuxdebianDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 7.0.68 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5351 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.69-10.el7 | RHSA-2016:2599 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 6 | tomcat7-0:7.0.54-23_patch_05.ep6.el6 | RHSA-2016:2807 |
| Red Hat JBoss Web Server 2.1 | tomcat7 | RHSA-2016:2808 |
| Red Hat JBoss Web Server 3.0 | see advisory | RHSA-2016:1089 |
| Red Hat JBoss Web Server 3 for RHEL 6 | httpd24-0:2.4.6-61.ep7.el6 | RHSA-2016:1087 |
| Red Hat JBoss Web Server 3 for RHEL 7 | httpd24-0:2.4.6-61.ep7.el7 | RHSA-2016:1088 |
Frequently Asked Questions
Is CVE-2015-5351 in your dependencies?
Find it across Maven, including transitive dependencies.