CVE-2015-5339 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle does not properly implement group-based access restrictions
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The core_enrol_get_enrolled_users web service in enrol/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly implement group-based access restrictions, which allows remote authenticated users to obtain sensitive course-participant information via a web-service request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 2.7.11composer require moodle/moodle:^2.7.11 |
| 🐘Packagist | moodle/moodle | ≥ 2.8.0&&< 2.8.9 | 2.8.9composer require moodle/moodle:^2.8.9 |
| 🐘Packagist | moodle/moodle | ≥ 2.9.0&&< 2.9.3 | 2.9.3composer require moodle/moodle:^2.9.3 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 2.7.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5339 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2015-5339 in your dependencies?
Find it across Packagist, including transitive dependencies.