NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2015-5337 — moodle

MEDIUMFix: moodle/moodle@c73f6d0

CVE-2015-5337 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle XSS Vulnerability

Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.53%1.05%1.58%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly restrict the availability of Flowplayer, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted .swf file.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versionsNo fix
🐘Packagistmoodle/moodle≥ 2.7.0&&< 2.7.112.7.11composer require moodle/moodle:^2.7.11
🐘Packagistmoodle/moodle≥ 2.8.0&&< 2.8.92.8.9composer require moodle/moodle:^2.8.9
🐘Packagistmoodle/moodle≥ 2.9.0&&< 2.9.32.9.3composer require moodle/moodle:^2.9.3

Affected Products

1 product · 24 configurations
Application
moodlemoodle
≤ 2.6.11
23 versions
2.7.02.7.12.7.22.7.32.7.42.7.52.7.62.7.72.7.82.7.92.7.102.8.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2015-5337; check the affected-versions list above or the advisory for the patched release of moodle/moodle, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly restrict the availability of Flowplayer, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted .swf file.
O3 Security · Impact-Aware SCA

Is CVE-2015-5337 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-5337: moodle XSS — Fixed in 2.7.11