NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2015-5321 — jenkins-core

Fix: jenkinsci/jenkins@251bdb0

CVE-2015-5321 is a Information Exposure vulnerability in org.jenkins-ci.main:jenkins-core. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Jenkins has Information Disclosure via Sidepanel Widget

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.88%1.76%2.65%0.2%2.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The sidepanel widgets in the CLI command overview and help pages in Jenkins before 1.638 and LTS before 1.625.2 allow remote attackers to obtain sensitive information via a direct request to the pages.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 1.626&&< 1.6381.638org.jenkins-ci.main:jenkins-core:1.638
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions1.625.2org.jenkins-ci.main:jenkins-core:1.625.2

Affected Products

2 products · 4 configurations
Application
jenkinsjenkins
≤ 1.637
range
Application
openshiftredhat
≤ 3.1
1 version
2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 1.638 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5321 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Enterprise 2.2activemq-0:5.9.0-6.redhat.611454.el6opRHSA-2016:0489
Red Hat OpenShift Enterprise 3.1atomic-openshift-0:3.1.1.6-1.git.0.b57e8bd.el7aosRHSA-2016:0070

Frequently Asked Questions

The sidepanel widgets in the CLI command overview and help pages in Jenkins before 1.638 and LTS before 1.625.2 allow remote attackers to obtain sensitive information via a direct request to the pages.
O3 Security · Impact-Aware SCA

Is CVE-2015-5321 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-5321: jenkins-core — Fixed in 1.638