CVE-2015-5301 — ipsilon
CVE-2015-5301 is a CWE-264 vulnerability in ipsilon. A fix is available for ipsilon — see the affected versions and patch details below.
Ipsilon denial of service by deleting a SAML2 Service Provider (SP)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
ipsilon🐍ipsilonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ipsilon | ≥ 0.1.0&&< 1.0.2 | 1.0.2pip install --upgrade 'ipsilon==1.0.2' |
| 🐍PyPI | ipsilon | ≥ 1.1.0&&< 1.2.0 | 1.2.0pip install --upgrade 'ipsilon==1.2.0' |
Affected Products
ipsilonipsilon_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ipsilon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ipsilon to 1.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5301 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2015-5301 in your dependencies?
Find it across PyPI, including transitive dependencies.